Sunday, July 20, 2008

Canada Post -- FAIL


Canada Post -- FAIL
Originally uploaded by mricon
Dear Canada Post:

It's one thing to claim that my version of Firefox is "insufficiently current" -- true, I need to upgrade to 3.0.1, but I have good reasons not to (broken deps galore). However, it's totally another to offer me a link to download Netscape or IE.

Dolts.

I fooled it easily with "Agent Switcher," but that's just broken.

1 comment:

Janina said...

Not only that, their Netscape download link gives a 404 (does a modern version of Netscape even exist?). Fail indeed.